PowWeb Forums - The Perfect Community for the Perfect Host  

Register now to interact with over 11,000 members! Registered users have Posting Privileges, free access to Private Messaging, Email Notifications and more.

Go Back   PowWeb Community Forums > Web Site Design > Web Site Design Software and Tools > Dreamweaver
User Name
Password
Register FAQ Members List Search Today's Posts Mark Forums Read

Closed Thread
 
Thread Tools
Old 1-15-05, 02:15 PM   #1
RBB
 
Join Date: Apr 2003
Location: Indianapolis
Posts: 213
Reputation: 39
FTP Question

My site is on io.powweb.com and is 2 years old. For two years I have been FTP'ing files from this computer. Beginning two days ago, I get the following notice when I attempt to connect to the server from this computer:

500 I won't open a connection to 192.168.29.138 (only to 199.8.28.9)

By the way, I get the same reply in Leech FTP (a freeware FTP program), in WS-FTP Pro, and from the FTP command prompt line. In Dreamweaver 4.0's built-in FTP "Site" function, I get the dialog box show below and it will not display the remote directory.

Any ideas on how to fix this? Thanks.

RBB
Attached Images
 
RBB is offline  
Old 1-15-05, 02:34 PM   #3
IanS
Former Spam Filter (EU)
 
IanS's Avatar
 
Join Date: Mar 2004
Location: Washington (THE original UK one!)
Posts: 12,911
Reputation: 488
Quote:
Originally Posted by RBB
My site is on io.powweb.com and is 2 years old. For two years I have been FTP'ing files from this computer. Beginning two days ago, I get the following notice when I attempt to connect to the server from this computer:

500 I won't open a connection to 192.168.29.138 (only to 199.8.28.9)

By the way, I get the same reply in Leech FTP (a freeware FTP program), in WS-FTP Pro, and from the FTP command prompt line. In Dreamweaver 4.0's built-in FTP "Site" function, I get the dialog box show below and it will not display the remote directory.

Any ideas on how to fix this? Thanks.

RBB
Have you changed your router recently or made some other network related changes locally? I ask this because 192.168.x.x is intended for local network user.
IanS is offline  
Old 1-15-05, 02:40 PM   #4
RBB
 
Join Date: Apr 2003
Location: Indianapolis
Posts: 213
Reputation: 39
Quote:
Originally Posted by IanS
Have you changed your router recently or made some other network related changes locally? I ask this because 192.168.x.x is intended for local network user.
As a matter of fact, yes! So it must be a local problem. Should have known. Thanks.
RBB is offline  
Old 1-15-05, 02:44 PM   #5
IanS
Former Spam Filter (EU)
 
IanS's Avatar
 
Join Date: Mar 2004
Location: Washington (THE original UK one!)
Posts: 12,911
Reputation: 488
Quote:
Originally Posted by RBB
As a matter of fact, yes! So it must be a local problem. Should have known. Thanks.
In which case, check the IP addresses of nodes - computers, printers and network related devices such as removable network cards. They should all be in the same 192.168.x.y with only y changing per machine (under standard or 'normal' setups.)
IanS is offline  
Old 1-15-05, 02:47 PM   #6
RBB
 
Join Date: Apr 2003
Location: Indianapolis
Posts: 213
Reputation: 39
Good to know. I appreciate it.
RBB is offline  
Old 1-15-05, 04:18 PM   #7
krisemas
Guest
 
Posts: n/a
I'm having the same problem. I just signed up with powweb and I cannot seems to connect via ftp and dreamweaver clients.

$ ftp ftp03.powweb.com
Connected to ftp03.powweb.com.
220-Welcome to Pure-FTPd.
220-You are user number 41 of 5000 allowed.
220-This is a private system - No anonymous login
220 You will be disconnected after 5 minutes of inactivity.
Name (ftp03.powweb.com:root): myname
331 User myname OK. Password required
Password:
230-User mysite has group access to: 500
230 OK. Current restricted directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
500 I won't open a connection to 192.168.1.8 (only to 69.225.6.69)
425 No data connection
ftp> cd htdocs
250 OK. Current directory is /htdocs
ftp> dir
500 I won't open a connection to 192.168.1.8 (only to 69.225.6.69)
ftp> ls
500 I won't open a connection to 192.168.1.8 (only to 69.225.6.69)
ftp> quit
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 Logout.

With dreamweaver, I got the same pop-up as above.

Any ideas?
 
Old 1-15-05, 04:21 PM   #8
IanS
Former Spam Filter (EU)
 
IanS's Avatar
 
Join Date: Mar 2004
Location: Washington (THE original UK one!)
Posts: 12,911
Reputation: 488
Quote:
Originally Posted by krisemas
I'm having the same problem. I just signed up with powweb and I cannot seems to connect via ftp and dreamweaver clients.

$ ftp ftp03.powweb.com
Connected to ftp03.powweb.com.
220-Welcome to Pure-FTPd.
220-You are user number 41 of 5000 allowed.
220-This is a private system - No anonymous login
220 You will be disconnected after 5 minutes of inactivity.
Name (ftp03.powweb.com:root): myname
331 User myname OK. Password required
Password:
230-User mysite has group access to: 500
230 OK. Current restricted directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir
500 I won't open a connection to 192.168.1.8 (only to 69.225.6.69)
425 No data connection
ftp> cd htdocs
250 OK. Current directory is /htdocs
ftp> dir
500 I won't open a connection to 192.168.1.8 (only to 69.225.6.69)
ftp> ls
500 I won't open a connection to 192.168.1.8 (only to 69.225.6.69)
ftp> quit
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 Logout.

With dreamweaver, I got the same pop-up as above.

Any ideas?
Two points here, have you waited long enough for propogation? When did you register? The other is to check any firewall you may have, try turning it off temporarily to see if you can connect. If you can without a firewall (so can others inwards) then at least you know it's a firewall configuration problem. (You do have a firewall installed, don't you )
IanS is offline  
Old 1-15-05, 04:31 PM   #9
krisemas
Guest
 
Posts: n/a
Quote:
Originally Posted by IanS
Two points here, have you waited long enough for propogation? When did you register? The other is to check any firewall you may have, try turning it off temporarily to see if you can connect. If you can without a firewall (so can others inwards) then at least you know it's a firewall configuration problem. (You do have a firewall installed, don't you )
Wow, that was fast!. I registered about 2 days ago and my domain was activated yesterday and I'm ready to upload my stuff.

Yes, I do have firewall at gateway (using ipchains) and on the client side I have ZoneAlarm installed. I can disable the ZoneAlaram, but not the the firewall on the gateway.
 
Old 1-15-05, 04:34 PM   #10
IanS
Former Spam Filter (EU)
 
IanS's Avatar
 
Join Date: Mar 2004
Location: Washington (THE original UK one!)
Posts: 12,911
Reputation: 488
Quote:
Originally Posted by krisemas
Wow, that was fast!. I registered about 2 days ago and my domain was activated yesterday and I'm ready to upload my stuff.

Yes, I do have firewall at gateway (using ipchains) and on the client side I have ZoneAlarm installed. I can disable the ZoneAlaram, but not the the firewall on the gateway.
Your domain may not be fully propogated. Try disabling the ZoneAlarm firewall for the moment. - Remember to turn it back on after you've finished trying.
IanS is offline  
Old 1-15-05, 04:45 PM   #11
krisemas
Guest
 
Posts: n/a
I disable my zonealarm but the problem still exists.

The ftp connection works on my linux machine, but not my windows machine.

$ ftp ftp03.powweb.com
Connected to ftp03.powweb.com.
220-Welcome to Pure-FTPd.
220-You are user number 41 of 5000 allowed.
220-This is a private system - No anonymous login
220 You will be disconnected after 5 minutes of inactivity.
500 This security scheme is not implemented
500 This security scheme is not implemented
KERBEROS_V4 rejected as an authentication type
Name (ftp03.powweb.com:root): myuser
331 User myuser OK. Password required
Password:
230-User myuser has group access to: 500
230 OK. Current restricted directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
227 Entering Passive Mode (66,152,97,20,152,188)
150 Accepted data connection
drwxr-xr-x 5 124878 500 4096 Jan 13 18:07 .
drwxr-xr-x 5 124878 500 4096 Jan 13 18:07 ..
drwxr-xr-x 2 124878 500 4096 Jan 13 10:27 cgi-bin
drwxr-xr-x 4 124878 500 4096 Jan 15 11:44 htdocs
drwxr-xr-x 2 124878 500 4096 Jan 13 18:07 logs
226-Options: -a -l
226 5 matches total
ftp>

When I looked at the linux FTP session, I figured out that the FTP connection is set to "passive" mode, so I set to passive mode on my windows machine and now it works. Now I have to figure-out how to set the passive mode on dreamweaver.

Thanks for the help.

Update: dreamweaver advanced settings allows you to enable "passive" mode. Everything is working fine now.
 
Old 1-17-05, 11:41 AM   #12
satis
 
satis's Avatar
 
Join Date: Oct 2002
Location: Dallas
Posts: 2,914
Reputation: 311
You have to have passive mode set because you're behind a router. Active mode means that the FTP site will actively attempt to contact your machine. Since your IP is being NATed, it's unable to do so.
__________________
Satis Clankiller
Clankiller.com Forums
Clankiller.com
PlasmaSky.com
satis is offline  
Old 1-29-05, 08:51 AM   #13
krisemas
Guest
 
Posts: n/a
They turn off the PASSIVE mode on the FTP see:
http://forum.powweb.com/showthread.php?threadid=46507

And now I'm unable to upload my files on my windows and linux platform.

$ ftp ftp03.powweb.com
Connected to ftp03.powweb.com.
220---------- Welcome to Pure-FTPd [TLS] ----------
220-You are user number 18 of 500 allowed.
220-Local time is now 04:41. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 3 minutes of inactivity.
500 This security scheme is not implemented
500 This security scheme is not implemented
KERBEROS_V4 rejected as an authentication type
Name (ftp03.powweb.com:user): myhost
331 User myhost OK. Password required
Password:
230-User myhost has group access to: customer
230 OK. Current restricted directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
500 Unknown command
Passive mode refused. Turning off passive mode.
500 I won't open a connection to 192.168.1.10 (only to 69.225.4.221)
ftp: bind: Address already in use


Now how am I suppose to upload/update my files?
 
Old 1-29-05, 03:14 PM   #14
IanS
Former Spam Filter (EU)
 
IanS's Avatar
 
Join Date: Mar 2004
Location: Washington (THE original UK one!)
Posts: 12,911
Reputation: 488
Quote:
Originally Posted by krisemas
They turn off the PASSIVE mode on the FTP see:
http://forum.powweb.com/showthread.php?threadid=46507

And now I'm unable to upload my files on my windows and linux platform.

$ ftp ftp03.powweb.com
Connected to ftp03.powweb.com.
220---------- Welcome to Pure-FTPd [TLS] ----------
220-You are user number 18 of 500 allowed.
220-Local time is now 04:41. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 3 minutes of inactivity.
500 This security scheme is not implemented
500 This security scheme is not implemented
KERBEROS_V4 rejected as an authentication type
Name (ftp03.powweb.com:user): myhost
331 User myhost OK. Password required
Password:
230-User myhost has group access to: customer
230 OK. Current restricted directory is /
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
500 Unknown command
Passive mode refused. Turning off passive mode.
500 I won't open a connection to 192.168.1.10 (only to 69.225.4.221)
ftp: bind: Address already in use


Now how am I suppose to upload/update my files?
Try turning PASV mode OFF - It may just work. I'm behind a NAT router and using firewall software on the workstation and it works here.
__________________
This is a Powweb customer
helping Powweb customer forum.

I am a customer just like you!!

Some matters can only be answered by staff or support.
Give it a go - ask here first!
IanS is offline  
Old 6-10-05, 06:08 AM   #15
bollitopet
Registered
 
Join Date: Jun 2005
Location: Madrid
Posts: 18
Reputation: 0
I'm also having the same problem.
I can send files with FTP Voyager but not with the command line ftp.
I've been looking how to change to the passive mode in the command line ftp but I don't find it.
Can anyone help me?
bollitopet is offline  
Old 6-10-05, 07:24 AM   #16
IanS
Former Spam Filter (EU)
 
IanS's Avatar
 
Join Date: Mar 2004
Location: Washington (THE original UK one!)
Posts: 12,911
Reputation: 488
Quote:
Originally Posted by bollitopet
I'm also having the same problem.
I can send files with FTP Voyager but not with the command line ftp.
I've been looking how to change to the passive mode in the command line ftp but I don't find it.
Can anyone help me?
This is an old thread that you've revived. The problem was resolved back in January.

The fact you can FTP with Voyager suggests the problem is unrelated to the one from January.

I suggest you post in either General Support Forum or Computer Help forum as this forum is for problems with Dreamweaver etc..
__________________
This is a Powweb customer
helping Powweb customer forum.

I am a customer just like you!!

Some matters can only be answered by staff or support.
Give it a go - ask here first!
IanS is offline  
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:00 AM.


Contents ©PowWeb, Inc. ~ vBulletin, Copyright 2000-2007 Jelsoft Enterprises Limited.